XIM Community

General Category => Technical Support => Topic started by: AffectedEnd7 on 03:13 AM - 03/12/21

Title: [ACTIVE] XIM apex not working
Post by: AffectedEnd7 on 03:13 AM - 03/12/21
My XIM apex powers on my controller vibrates but does not turn on which causes my keyboard and mouse to not power on Iím on the Xbox one s with a regular one a controller just recently has been happening
Title: Re: XIM apex not working
Post by: mist4fun on 10:06 AM - 03/12/21
Welcome to the community. There's more than one cause for this but it's usually setup related and can be fixed. To help fix the problem can you please go through the list linked below and share the results from each step? This may also resolve the issue.

Some of the results will pass assuming that your non-XIM devices are working normally. If it does not resolve the problem then we can use the combined results from each numbered step to find a solution.

https://community.xim.tech/index.php?topic=61565.0
Title: Re: [ACTIVE] XIM apex not working
Post by: AffectedEnd7 on 11:53 PM - 03/13/21
I did all of it and it didnít resolve the problem I moved the wire connected to the hub while nothing was plugged into it and it started flashing red and yellow so I took the top casing off and the wires are split and touching each other I have a feeling it is shorting itself out can I get a new hub?
Title: Re: [ACTIVE] XIM apex not working
Post by: mist4fun on 09:30 AM - 03/15/21
Thanks for taking the time for that. That's interesting, I would really like to see that if you're able to share a picture. This may be useful for support in the future.

In the meantime, can you test the hub (with peripherals) connected to a PC instead of XIM? Does an issue happen there too?