XIM Community

General Category => Support => Topic started by: ClashCowboy on 06:12 PM - 06/26/20

Title: [ACTIVE] Xim 4 disconnecting peripherals
Post by: ClashCowboy on 06:12 PM - 06/26/20
Hi,
I have had my xim for around 2 years now without any issues. However, recently the xim keeps disconnected keyboard, mouse and controller intermittently.
The keyboard and mouse are the same as I've always had.
 I've replaced all the micro usb cables, changed controller, changed the xbox, updated the firmware.
The app still shows all connected after it fails too.

Any help or ideas would be great
Thanks
Title: Re: Xim 4 disconnecting peripherals
Post by: Od1n on 08:41 PM - 06/26/20
Have you updated your XIM firmware? Maybe the console updated your controller firmware and your 2 years old XIM firmware doesnt work with that one anymore.
Also if your controller uses a battery pack, can you remove it and try again?

Another thing you can do is to fully shut down the console and remove the external power supply from the socket, after around a minute you can connect it to the socket again and redtry.
Title: Re: Xim 4 disconnecting peripherals
Post by: ClashCowboy on 04:45 AM - 06/27/20
Hi,
Thanks for the reply.
Yes I have updated the firmware and completed power cycles. Honestly feel like I've tried everything I can. Only thing i havent done so far is change the xim, mouse and keyboard, maybe one of those suddenly require more power than before.
Something to note is that once the xim is unplugged and plugged back in it works immediately again. But it's just a matter of time before it happens again.
Thanks
Title: Re: Xim 4 disconnecting peripherals
Post by: OBsIV on 12:11 PM - 06/27/20
Do they all disconnect at the same time when it happens?
Title: Re: [ACTIVE] Xim 4 disconnecting peripherals
Post by: ClashCowboy on 04:25 PM - 06/27/20
 I reinstalled the firmware update and it seems to have fixed the problem. Must have been corrupt previously I guess?
Thanks for the help
Title: Re: [ACTIVE] Xim 4 disconnecting peripherals
Post by: ClashCowboy on 01:15 PM - 06/28/20
So it worked for 1 evening. Its now gone back to disconnecting
Title: Re: [ACTIVE] Xim 4 disconnecting peripherals
Post by: OBsIV on 01:37 PM - 06/28/20
Do they all disconnect at the same time when it happens?
Title: Re: [ACTIVE] Xim 4 disconnecting peripherals
Post by: ClashCowboy on 01:29 AM - 06/29/20
Yes they do.
The mouse, keyboard and controller all disconnect at the same time. However it does not state to reconnect controller on screen. Once unplugged and plugged back in, it says to reconnect controller and then it will work straight away until it decides to disconnect again.
Title: Re: [ACTIVE] Xim 4 disconnecting peripherals
Post by: mist4fun on 09:38 AM - 06/29/20
Have you tested other data cables between XIM and console? If not I would try this next. If using an extension or extra devices be sure to remove these while troubleshooting.

Could you please share your setup so we can learn more about the issue? Please include both the brand and model.

mouse:
keyboard:
extras: extended usb cables, third party usb hub, usb switch, titan or cronus device?