XIM Community

General Category => Support => Topic started by: Azi8tic on 09:20 PM - 05/11/20

Title: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 09:20 PM - 05/11/20
I have seen this topic posted many times and I apologize for beating a dead horse.

Settings:
XIM Apex Manager version: 5.00.20190804
Firmware Version: 5.00.20200307
Mouse: G502 wired
Platform: PS4 pro
Controllers: CUH-ZCT2U
iPhone 10: Running 13.3.1

Problem:
I upgraded from XIM4 to XIM Apex.  I have the PS controller in port 3.  Mouse in port 1.  And I turn on my NAV controller for wirelessly play.  The videos helped me properly set the NAV up since setup is different from the XIM 4.

Unfortunately, I accidentally plugged the NAV controller directly into the PS4 via mini-usb to charge it.  This started my problem.  I broke the sync between the XIM APEX and the NAV.  The NAV now connects directly to the PS4.  I can no longer get the XIM APEX to recognize the NAV.  The NAV no longer appears in the APEX manager whether plugged into port 2 or 1 or wirelessly.

Troubleshooting Steps:
I have (2) Mini-usb cables and I confirmed they both work because I plugged the NAV directly to the PS4 (after resetting the NAV controller) and the PS4 recognized the NAV, charged the NAV and received buttons input from the NAV while wired.

1. I reset the NAV again, and made sure it was off. 
2. I unplugged the XIM APEX. 
3. I plugged the PS controller in Port 3. 
4. I plugged the NAV in port 1. 
5. I turned on the PS4 and I plugged the XIM APEX into the PS4. 
6. The manager shows the PS controller but no NAV. 

None of the inputs from the NAV appear. 

7. I unplugged the NAV and plugged in my mouse to port 1.  It recognizes it immediately.  If I turn on the NAV via the (PS) button, it blinks and stops as if it couldn't connect to anything. 

8. I made sure the NAV is fully charged per the full battery icon that appears on-screen when I plugged the NAV directly to the PS4. 
9. I switch mini-usb cables.  Same result. 
10. I reverted back to my old XIM4 using the NAV wired in and the it works seamlessly.  All peripherals appear as expected while using the XIM4 and old XIM manager.  Why is the XIM APEX so difficult with the NAV.

I'm not sure what else to do.  It was working for months and stopped the second I plugged the NAV into PS4 and broke the sync, now nothing I do helps it re-sync.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: antithesis on 03:46 AM - 05/12/20
Is there a reset button on the Nav?
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 09:35 AM - 05/12/20
Yes.  The NAV controller has a reset button.  I had to reset it so that it would no longer connected directly with the PS4 when activated.  Please advise.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 09:42 AM - 05/12/20
http://www.mtcservice.com/manuals/CECH-ZCS1U-Move-Navigation_Eng.pdf

The reset button is on the back. You have done everything right, OP. Unfortunately this does happen sometimes and there is no solid fix that I know of except for time. I've run into the issue myself a couple of times. The reset button, charging, depleting the battery, using other cables, powering off the paired console, attempting to use other XIMs, ect. It favors the console. It's happened twice to me and each time I just put it in a drawer and it eventually works later.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: antithesis on 04:00 PM - 05/12/20
Does allowing the Nav to fully discharge before reset help?
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 04:25 PM - 05/12/20
Yeah, I guess discharging the battery completely might have something to do with it.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 06:19 PM - 05/12/20
Welp, after being told there was nothing I can do, I kinda gave up.

@antithesis I have not actually attempted to fully discharge the battery.  Here is what I will do.

I have the XIM4 plugged into my MacBook: The NAV controller appears on my XIM4. I'll disconnect the NAV from the mini-usb cable and it should stay on and connected via Bluetooth until it dies.

In the interim, I'll use my XIM Apex with my (left) Nintendo switch controller so that I can still play my games with my XIM Apex setup.  I just hate that small controller.

I will advise of the outcome.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 09:13 AM - 05/13/20
I hope it resolves itself soon. Once it does, the nav can't be charged with USB chargers but can be charged using a PC and possibly another console that is not PS3 or PS4.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 05:42 PM - 05/16/20
I have good news and bad news:

After about (2) days of play with my NAV (wirelessly) connected to my XIM4, the NAV battery finally discharged fully.  This is good news because it signifies the battery on this NAV is quite strong and long lasting.

I left the NAV completely dead for two hours to ensure all RAM was depleted.  I then used a brand new optimal data transfer mini USB 2.0 cable (ordered on Amazon and received today) to charge the NAV.  I charged it using my MacBook.

I plugged the PS4 controller into port '3'.  I plugged the NAV into port '1'.  I plugged the XIM APEX into the PS4, PS4 controller lights up.  NAV does not.  Bad news: same problem exist. 

I performed other tests, I placed PS4 controller in port '3'.  Dell keyboard in port '2'.  G502 mouse in port '1'.  All devices registered on XIM Apex.  It also appeared hot-swappable.  Meaning I can pull the peripherals out and back in and the XIM Apex would reinitialize those devices. 

There is either something wrong with my XIM Apex or the NAV.  The NAV connects directly to the PS4 and XIM 4 (using any cable) with zero issue.  The NAV unit is fully charged.  The XIM APEX recognizes every other peripheral I own but the NAV.  I purchased this XIM APEX and my XIM4 directly from your XIM store on Christmas.  If I pony up $80 on Amazon for another NAV controller and it still doesn't work, that is really going to suck.

Any other suggestions?
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: antithesis on 06:46 PM - 05/16/20
Check PS4 > Settings > Devices > Controllers > Communication Method > Use USB Cable.
Title: Re: PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 07:20 PM - 05/16/20
Yes, the PS4 is set to "Use USB cable" as connection method for the past (6) months.
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 09:33 AM - 05/18/20
Keep the nav for a while and try again after waiting a longer period of time. It should eventually be able to pair with other things.
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 07:36 PM - 05/19/20
Evening,

I let the NAV fully discharge again.  This time I let it remain 'dead' for 48 hours.  Next, I fully charge it with my MacBook.  Once fully charged, I set it up with the XIM Apex and the same results occurred.

At this point, my XIM Apex is unusable because I don't play games with a keyboard and the Nintendo Switch controller is incredibly small.  Is there any way to test to see if the hub is this problem?  I had an issue with the XIM Apex upon its first  arrival.  I was able to get the mouse to work but not the NAV.  I figured it was inexperienced and not watching the setup videos.  I was able to get it to work after a day.  This time nothing is working. 

My NAV has zero problems authenticating with my PS4 and XIM4.  My Mac even recognized the NAV when connected via a USB cable.  But there is no communication between the HUB and the NAV.  Regardless of port '1' or '2'.  Nothing. 

Is it at all possible my problems stem from a defected hub and what isolation steps could I use to test?
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 09:12 AM - 05/20/20
You could test the hub with a PC using peripherals in each port but this will just tell you if the port is working or not. Ideally testing another hub would be most helpful.
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 04:31 PM - 05/28/20
I can buy a new hub today.  Shouldn't be too expensive.  What hub would you recommend?  Will any 3-port USB hub work?  Please advise.
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 05:03 PM - 05/28/20
Yes, any USB 2.0 hub with at least 3 usb ports should work with your XIM. While 2.0 is officially supported 3.0 has been reported to work as well. If you're buying a new hub I would try to purchase a hub that includes a power adapter, just in case your setup needs it now or in the future.
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: Azi8tic on 03:36 PM - 05/31/20
@Mist4fun

This issue has been resolved.

I purchased a 4-Port USB 3.0 Hub with power adapter from Atolla.  Unfortunately, it doesn't appear this USB Hub is compadible (sp) with XIM APEX.  None of the devices appear.  I purchased a 3.0 Hub because I wanted to it be useful for future editions of XIM.  But when it didn't work, I almost gave up.

I looked up the community threads for hubs that worked.  Apparently, Atolla hubs work and the Atolla power adapter also works in the XIM APEX hub.  I didn't even know the XIM Apex usb hub could be powered.  I plugged the Atolla power adapter into the APEX XIM hub along with the devices and it worked, the NAV controller appears and was recognized instantly. 

It's safe to say that that power adapter would have resolved all of my problems day 1 when the APEX first arrived.  Thank you to you and the community for resolving my problem. 
Title: Re: [Q/A] PS3 NAV controller no longer recognized by XIM Apex
Post by: mist4fun on 09:31 AM - 06/01/20
I'm glad your setup is working now. It's strange that you Nav is fully charged but it doesn't work without a power adapter while connected to APEX and at the same time it works with the console without XIM connected. That's a tricky one, thanks for sharing your fix.