XIM Community

General Category => Support => Topic started by: antithesis on 05:42 AM - 07/20/19

Title: [RESOLVED] Joystick Up (J-up) overriding input on Xbox One...
Post by: antithesis on 05:42 AM - 07/20/19
A customer of mine picked up a XIM Apex today and reported an interesting issue I haven't seen before.

On Xbox One, mouse and keyboard input is being overridden by "J-up" that seems to be coming from the connected Elite controller. The button isn't bound in his Apex Legends config.

He has the Elite, a Razer Naga mouse and a kb attached (I don't know the model). AFAIK, no CronusMAX or Titan is connected.

I just tested an Elite controller on my XIM Apex and I can see all regular button presses detecting and outputting in XIM Manager as expected (e.g D-pad Up registers as "Up") so I'm confused as to where J-up might be coming from.

Any idea what this could be?

At a guess I'm thinking custom Elite controller profile setting, or maybe one of the side-buttons on his Razer Naga mouse. I also thought it could be stick drift, or a faulty USB cable, but neither explains why "J-up" appears in XIM Manager. None of these explains why disabling stick input via XIM Manager > Apex Legends > HIP > Analog works.

I'll send him a link to this thread if he has anything further to add, but this one has me stumped  :o
The only time I've experienced similar symptoms is when using Fragpedal foot pedals directly attached to XIM Apex (same solution).
Title: Re: Joystick Up (J-up) overriding input on Xbox One...
Post by: antithesis on 06:07 AM - 07/20/19
Quick update - the kb is the Roccat ISKU+ Force FX. It's the one with the analog QWEASD cluster.

I'm dead certain that's the problem and the solution he's implemented is the only one I can think of.

Anyone have similar experience with this keyboard? Any alternative solutions?

Based on my own experience with Fragpedal, it's exactly the same issue (the analog cluster is outputting a DirectInput joystick signal when disconnected from PC) and he's already nailed the solution.

Mouse, keyboard and Elite should all be working fine.
Title: Re: Joystick Up (J-up) overriding input on Xbox One...
Post by: OBsIV on 06:26 PM - 07/20/19
Can you have them ensure the firmware is up-to-date on their Elite?
Title: Re: [ACTIVE] Joystick Up (J-up) overriding input on Xbox One...
Post by: antithesis on 01:05 AM - 07/21/19
It's not the Elite, I'm 100% convinced it's the QWEASD analog cluster on the Roccat kb. The symptoms are exactly the same as Fragpedals and the solution is working fine.

He's returned the kb in any case, so we can mark this as resolved. I don't see any other solution than disabling the joystick input from the Roccat kb, which is possible to do using XIM Manager  :D
Title: Re: [ACTIVE] Joystick Up (J-up) overriding input on Xbox One...
Post by: OBsIV on 09:39 AM - 07/21/19
This would have to be done in firmware, but, I don't understand why any device would constantly hold down a button -- sounds like a bug that the device manufacturer needs to fix. :)
Title: Re: [ACTIVE] Joystick Up (J-up) overriding input on Xbox One...
Post by: antithesis on 03:52 PM - 07/21/19
Yep, it's a product issue, not a XIM one. The device is outputting DirectInput joystick signals at all times and is misbehaving when not connected to PC.

Fragpedal fixed the same issue and I've tested it on XIM Apex with no problems. Apparently the output of the joystick signal is in the range of -155 to +155. Setting this to -100 to +100 fixes it for consoles. Fragpedal will be releasing a firmware update in a couple of months with this fix as part of the overall update.

I recall seeing the Fragpedal output in Gtuner IV for Titan Two and it was registering a constant 101.XX for both L & R joystick axes. Using a script to force it to 100 likewise fixed the problem.

In any case, there's a fix if this crops up again by disabling the Joystick input via the Analog section of XIM Manager.
Title: Re: [ACTIVE] Joystick Up (J-up) overriding input on Xbox One...
Post by: mist4fun on 09:15 AM - 07/22/19
It's the Roccat keyboard. A lot of their devices have a virtual joystick that always sends input. I used to think it was exclusively for their 'fin' button that their mice use but I've been seeing keyboard reports like this as well.

In any case, there's a fix if this crops up again by disabling the Joystick input via the Analog section of XIM Manager.

Yep. I'm glad you were able to find that.