XIM Community

XIM 4 => Hardware Compatibility => Topic started by: OneHandedGamer on 05:24 AM - 07/11/18

Title: Controller not being recognized
Post by: OneHandedGamer on 05:24 AM - 07/11/18

Back in December 2015, I bought a XIM4 to be able to play PS4 with my one handed PS2 controller, which can be converted to a PS3 controller via an adapter, and I never really had any lasting issues with it.

However, just recently I bought a new one handed controller (the exact same model as I had before, which worked perfectly fine), because the old one got kind of worn out. https://www.amazon.co.uk/Sony-Playstation-handed-Dragon-controller-x/dp/B005EQTSLC
And for some reason my XIM4 does not recognize it, both controllers do light up, so I know they are getting power and are connected properly to my XIM4. But when I try to set up my controls, it doesn't recognize me pushing the buttons on my one handed controller, the XIM4 manager app keeps saying 'listening...'.

I've already tried using different ports, different cables, a factory reset and updated my firmware several times. None have worked so far. If someone would know a solution for this, I'd be very grateful.
Thanks in advance!

Kind regards,
Title: Re: Controller not being recognized
Post by: OneHandedGamer on 05:40 AM - 07/11/18
Nevermind, I don't know how I fixed it, but it works again! :)
Title: Re: Controller not being recognized
Post by: mist4fun on 10:26 AM - 07/11/18
That's interesting. If something like this happens again or if you think another peripheral would work better but isn't supported you may be able to a PC and the SandhawC app. XIM4 would connect to a PC using a transfer cable and also connect to your console. XIM4 would use peripherals attached to your PC to drive input on your console. More info on this here: