XIM Community

General Category => Support => Topic started by: Incubo132 on 01:39 PM - 06/14/18

Title: [RESOLVED] Xim4 Troubles
Post by: Incubo132 on 01:39 PM - 06/14/18
So I just updated my xim4 and now when I plug everything in and try to turn on my control it wont turn on and the xim4 keeps giving the "breathing" effect.  Can someone please help?
Title: Re: Xim4 Troubles
Post by: mist4fun on 02:21 PM - 06/14/18
Welcome to the community. I would start by verifying everything is connected in the right port order and reseat the connections.

port 1: mouse
port 2: keyboard
port 3: controller

After this let's try a hard reset, it can sometimes fix this issue. Press and hold the power button on the front of the console for 15 seconds. Once off unplug the power cable to the console for 60 seconds. Reconnect the power cable and power on the console. Attach all peripherals to XIM then connect XIM to the console.

Note that removing the power cable while off has been reported as necessary by some users.
Title: Re: [ACTIVE] Xim4 Troubles
Post by: Incubo132 on 02:34 PM - 06/14/18
What if that doesn't work what would be the next plan that would work?
Title: Re: [ACTIVE] Xim4 Troubles
Post by: mist4fun on 02:47 PM - 06/14/18
Next you would look for the controller authenticating, you should see 4x green lights from XIM during startup. You should also see a controller icon at the top of Manager. If the hard reset doesn't work and afterward you do not see these things then you may want to try moving the controller to another port on XIM4. If this doesn't work then replacing the controller cable with a known working data cable would be the next step.
Title: Re: [ACTIVE] Xim4 Troubles
Post by: Incubo132 on 02:58 PM - 06/14/18
I use ios and the xim4 won't show up when my phone is searching for devices. So there is a lot that is going on with my xim4. It honestly upsets me due to the fact I've barely used it, I also know that it is not the cable that is connected to my controller due to the fact I have switched the cable 3 times trying to get the "breathing" effect to go away.
Title: Re: [ACTIVE] Xim4 Troubles
Post by: mist4fun on 04:25 PM - 06/14/18
XIM4 uses Bluetooth LE on iOS and will not be visible as a pairing option in bluetooth settings. Pairing is done in the app instead.

The breathing effect is normal, XIM4 will breathe the active config color.

Before you retry pairing unplug XIM4 then reconnect it to the console. Since the iOS 11 update users have had success by toggling bluetooth and airplane mode off and on again in both control center and phone settings. I recommend closing Manager and unplugging APEX before you attempt this again.
Title: Re: [ACTIVE] Xim4 Troubles
Post by: Incubo132 on 07:18 PM - 06/14/18
okay when I press the PNS button it still shows that the controller is still off.
Title: Re: [ACTIVE] Xim4 Troubles
Post by: mist4fun on 06:57 AM - 06/15/18
Pressing the PS button isn't necessary to pair or use XIM. Could you share the firmware version number found in menu-about? This will start with 4.00.

Were you able to get Manager working using the advice above?
Title: Re: [ACTIVE] Xim4 Troubles
Post by: Incubo132 on 10:08 AM - 06/15/18
firmware is 4.00.20160405
Title: Re: [ACTIVE] Xim4 Troubles
Post by: mist4fun on 10:18 AM - 06/15/18
Thanks, this firmware is out of date and doesn't have the latest controller support. I would start by updating the firmware using a PC or Mac.

You can find the latest XIM4 firmware below. Please read the instructions on the download page.

http://community.xim.tech/index.php?topic=49093.0
Title: Re: [ACTIVE] Xim4 Troubles
Post by: Incubo132 on 11:34 AM - 06/15/18
Thank you so much it was honestly to the point where i was upset and now it works im so happy
Title: Re: [ACTIVE] Xim4 Troubles
Post by: mist4fun on 11:36 AM - 06/15/18
Of course, I'm glad that helped.