XIM Community

Xim4 question! Hopefully Iím not the only one!  (Read 272 times)

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Xim4 question! Hopefully Iím not the only one!
« on: 08:30 AM - 05/31/18 »
Hello!

Please forgive me if I didnít post this is the right forums. I havenít been on this website in a while because Iíve been pretty stable in my xim4 and there hasnít been any issues.

...up until recent. :(

Iíve been having problems connecting my xim4 to my iPhone. Iím assuming itís related to Bluetooth? My iPhone is very new and hasnít had any problems connecting to any Bluetooth device so far, just my Xim4.
If anyone has come across this little problem, iíd love to hear some feedback. I appreciate the xim community a bunch and Iíve always been helped in the past, especially from the wonderful mods. :)

Anyways, I hope everyone has a great day! Thank you again for reading and Iím crossing my fingers thereís a simple  solution and Iím not the only one experiencing this problem.

Xim4
iPhone 6+
Mouse: Logitech G502
Keyboard: Logitech G13

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 32992
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #1 on: 09:28 AM - 05/31/18 »
I do know that there is some strange interface design in OS11 where it looks like Bluetooth is fully on for all devices even though it isn't. Can you please try toggling Bluetooth in your system settings and also within the action center? Also, please try rebooting your phone too.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #2 on: 09:32 AM - 05/31/18 »
I do know that there is some strange interface design in OS11 where it looks like Bluetooth is fully on for all devices even though it isn't. Can you please try toggling Bluetooth in your system settings and also within the action center? Also, please try rebooting your phone too.

Iíve tried rebooting my phone and Iíve tried turning on/off my Bluetooth options. Itís weird because last night I tried using my xim and was having problems but I tried this morning and it worked for a total of around 10 minutes. Then it stopped working when I tried swapping my configs. Literally in the middle of the game. Itís really odd.

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #3 on: 09:32 AM - 05/31/18 »
Also, thank you for the fast reply! I appreciate it a lot :)

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 44170
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #4 on: 10:13 AM - 05/31/18 »
Check airplane mode as well. Since the iOS 11 update users have had success by toggling bluetooth and airplane mode off and on again in both action center and phone settings. I recommend closing Manager and unplugging APEX before you attempt this again.

I do know that there is some strange interface design in OS11 where it looks like Bluetooth is fully on for all devices even though it isn't. Can you please try toggling Bluetooth in your system settings and also within the action center? Also, please try rebooting your phone too.

I tried this morning and it worked for a total of around 10 minutes.

Did XIM4 stop working in your game or was this just Manager that stopped working? If it was just Manager you may also want to look at other bluetooth pairings you have, they may be connecting on their own which will prevent a connecting with your XIM4. To troubleshoot this consider temporarily removing all other bluetooth pairings with your phone then attempt to use Manager for as long as possible to see if one of the old pairings was conflicting.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #5 on: 10:37 AM - 05/31/18 »
Check airplane mode as well. Since the iOS 11 update users have had success by toggling bluetooth and airplane mode off and on again in both action center and phone settings. I recommend closing Manager and unplugging APEX before you attempt this again.

I do know that there is some strange interface design in OS11 where it looks like Bluetooth is fully on for all devices even though it isn't. Can you please try toggling Bluetooth in your system settings and also within the action center? Also, please try rebooting your phone too.

I tried this morning and it worked for a total of around 10 minutes.

Did XIM4 stop working in your game or was this just Manager that stopped working? If it was just Manager you may also want to look at other bluetooth pairings you have, they may be connecting on their own which will prevent a connecting with your XIM4. To troubleshoot this consider temporarily removing all other bluetooth pairings with your phone then attempt to use Manager for as long as possible to see if one of the old pairings was conflicting.

Hey Mist! I remember you from a super long time ago. You were one of the mods that helped me a long time ago. :) haha!

The xim app didnít stop working, it just went to the red screen that says ďconnectĒ. Then it would take about 20 seconds and show the same page after attempting to connect. When I tried closing and reopening the app, it would (sometimes) work. But then would cut off if I tried doing anything on the app. If on the rare occasion it would work and stay connected, the best bet for me would to not touch the app and it would automatically lock on to the first config I have up. But if I tried to change it, it would freeze up and disconnect.

The only thing I have bluetoothíed to my phone is my ThunderMax speaker. I will try and disconnect that and remove it from the list. I donít know if that would really affect my xim though... itís always been connected to my phone but the speaker is dead completely so... I rarely use it. Lol
But iíll Try it out. Hopefully it works. :)

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #6 on: 11:18 PM - 05/31/18 »
Did XIM4 stop working in your game or was this just Manager that stopped working? If it was just Manager you may also want to look at other bluetooth pairings you have, they may be connecting on their own which will prevent a connecting with your XIM4. To troubleshoot this consider temporarily removing all other bluetooth pairings with your phone then attempt to use Manager for as long as possible to see if one of the old pairings was conflicting.

So Iíve checked with my Bluetooth and my xim and this is the problem so far:

Iíve removed all other Bluetooth devices off my phone and it still has the same problem.
I noticed my Bluetooth would turn off by itself, disconnecting itself with my iPhone. Airplane mode never turned on at all, so that wasnít the issue.
Is this a problem with my phone? Itís never done this before. :(

Offline YAASSSGAGA

  • Member
  • *
  • Posts: 14
    • View Profile
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #7 on: 01:38 AM - 06/09/18 »
Has there been any conclusion to this? Has anyone else had this problem?

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 32992
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Xim4 question! Hopefully Iím not the only one!
« Reply #8 on: 09:34 AM - 06/09/18 »
Do you have any other phone you can use just to verify something isn't wrong with your XIM4's Bluetooth radio?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.