XIM Community

[ACTIVE] xim4 not connecting  (Read 499 times)

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
[ACTIVE] xim4 not connecting
« on: 06:00 PM - 02/05/18 »
MY xim4 is connected to my google pixel 2 yet it doesnt connect to the app it just says connecting and nothing else. and it gives a purple color
« Last Edit: 06:15 PM - 02/05/18 by mist4fun »

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
xim4 not connecting
« Reply #1 on: 06:14 PM - 02/05/18 »
my xim4 is connected to my cell phone but when I open it, it shows connecting and a purple light turns on and it just stays that way

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #2 on: 06:16 PM - 02/05/18 »
Welcome to the community. Let's have you factory reset using the latest firmware. Once the reset is complete you will be required to un-pair then re-pair.

You can find the latest firmware below. Please read the instructions on the download page.

http://xim.tech/latest
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #3 on: 06:36 PM - 02/05/18 »
I dont know where to donwload the xim flash tool is that different from the app

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 26777
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #4 on: 06:49 PM - 02/05/18 »
yes its different, mist provided the link to it above
alternatively here is the link again, instructions can be found under the link

http://xim.tech/latest
PS4 & X1 | C: MS | XIM4 | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Zowie EC1-A | D: 3200 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

Check out my Youtube Channel: XIMGameplay
Du sprichst Deutsch? Hier gehts zum deutschen Forum

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Now i did a factory reset
« Reply #5 on: 06:53 PM - 02/05/18 »
When I did it i can connect and setup every thing the problem is that now it connects and after like 10 seconds it flashes yellow and it disconnects

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #6 on: 07:05 PM - 02/05/18 »
You may need to charge your controller. Connect the controller directly with the console for 1 hour. XIM4 should be disconnecting while charging.

About the yellow light, when a device has disconnected XIM4 will flash the problem port number in three sets of yellow. Example:

port 1: 1 flash x 3 sets
port 2 : 2 flash x 3 sets
port 3 : 3 flash x 3 sets

Do you know how many flashes there were per set?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #7 on: 07:19 PM - 02/05/18 »
Well right now it shows red and doesnt want to connect it is connected but i cant control it . I cant even config on my app

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #8 on: 07:29 PM - 02/05/18 »
Try charging the controller for 1 hour direct with the console. Unplug XIM4 while charging. If this doesn't help then replacing the controller cable may help.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #9 on: 08:18 PM - 02/05/18 »
I changed the cable it didnt work I am using other cables than the one came with the xim4 coz i lost it i assume this wont cause a problem since both of them are the same I mean it acts as if it isnt working it connects to the cell phone but it doesnt respond

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #10 on: 08:50 AM - 02/06/18 »
We need to gain more information about the issue you're having. Let's connect the XIM4 to the console with nothing attached to it. Remove all devices then connect XIM4 to the console.

We are going to check if you experience the same shutdown with nothing attached. Let it sit for 30 seconds after starting up then connect only the controller. Let sit for a few seconds then connect your mouse, wait, then connect your keyboard. At which point does it shut down and flash yellow lights?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #11 on: 10:42 PM - 02/08/18 »
The XIM4 is not working. It gives me red light when everything is connected and when i remove the joystick it gives me yellow light. It connects to the cell phone but when i try to change the configuration it doesnt work as if its not connected.
Again it gives thes red light when everything is connected and when i disconnect the joypad it gives a yellow light. I have just made a factory reset

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #12 on: 09:12 AM - 02/09/18 »
The light behavior you have mentioned is normal. XIM4 will breathe the config color, in this case red. XIM4 will flash yellow lights when it loses connection to a peripheral.

Did you attempt this test? Note the order of events, XIM4 should be started with nothing attached.

We need to gain more information about the issue you're having. Let's connect the XIM4 to the console with nothing attached to it. Remove all devices then connect XIM4 to the console.

We are going to check if you experience the same shutdown with nothing attached. Let it sit for 30 seconds after starting up then connect only the controller. Let sit for a few seconds then connect your mouse, wait, then connect your keyboard. At which point does it shut down and flash yellow lights?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Ismai

  • Member
  • *
  • Posts: 20
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #13 on: 09:16 AM - 02/09/18 »
yes i tried it and it didnt show any change of light it is always red

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 42293
    • View Profile
Re: [ACTIVE] xim4 not connecting
« Reply #14 on: 09:21 AM - 02/09/18 »
Ok, so it sounds like you're not longer experiencing random yellow lights, this is only occurring when you're physically removing peripherals from XIM4. This is normal.

If the XIM4 is still not responsive then this could be caused by:

- Controller cable
- XIM4 cable
- Controller
- XIM4 C port
- XIM4

We will need to troubleshoot each of these to find and fix the issue. Going forward do not connect your mouse and keyboard to XIM4. We will be testing using only XIM4 and the controller then pressing buttons on the controller and looking for a response Manager's HUD screen below the game picture.

1) Try connecting the controller to another port on XIM4. Port 3 is the preferred port but other ports should be tested.
2) Try using another cable that is known to work with data with the controller.
3) Try the replacement cable between XIM4 and console.
4) In rare instances it can be the micro usb port on the controller. Testing another controller would tell us if the controller is at fault. XIM4 supports first party controllers by the console manufactures. Third party controllers aren't supported.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos