XIM Community

DPI on DeathAder Elite does not work  (Read 78 times)

Offline LilJs

  • Member
  • *
  • Posts: 46
    • View Profile
DPI on DeathAder Elite does not work
« on: 04:03 PM - 01/13/18 »
So basically I use 3.2k DPI on my G900 but I also have a DeathAdder Elite, and wanted to try it..

I set to only have 2 DPI profiles on Synapse (800 and 3200DPI) but whenever I connect to the XIM i adjust the DPI with the buttons and I have like 4 or 5 different senses and they're not what I set..?

Offline LilJs

  • Member
  • *
  • Posts: 46
    • View Profile
Re: DPI on DeathAder Elite does not work
« Reply #1 on: 04:04 PM - 01/13/18 »

Offline akimboslash

  • Member
  • *
  • Posts: 20
    • View Profile
  • Gamertag: Yeoq
  • PSN ID: akimboSLASH-
Re: DPI on DeathAder Elite does not work
« Reply #2 on: 06:49 PM - 01/13/18 »
The deathadder and most razer peoducts dont have onboard memory like logitech mice, therefore, you cant set the dpi on synapse and have it save on the xim.

Offline alanmcgregor

  • Member
  • *
  • Posts: 99
    • View Profile
  • PSN ID: alanmcgamer
Re: DPI on DeathAder Elite does not work
« Reply #3 on: 07:08 PM - 01/13/18 »
Exactly, only the new Lancehead Tournament Edition and Wireless has built-in memory, even tough you have to be sure to load and select the profile while connecting to the XIM4

Offline uhsoka

  • Member
  • *
  • Posts: 17
    • View Profile
Re: DPI on DeathAder Elite does not work
« Reply #4 on: 02:30 AM - 01/14/18 »
So basically I use 3.2k DPI on my G900 but I also have a DeathAdder Elite, and wanted to try it..

I set to only have 2 DPI profiles on Synapse (800 and 3200DPI) but whenever I connect to the XIM i adjust the DPI with the buttons and I have like 4 or 5 different senses and they're not what I set..?
I use a death adder elite and it works fine. The dpi buttons(dpi profiles) don't work properly though. I think its increases or decreases the dpi by 500 or 1000 everytime you click it. Everytime I change my dpi, I plug my deathadder into my laptop, open up synapse, set my dpi, close synapse, unplug mouse, then plug into xim and you should be set. Don't use the dpi buttons.