XIM Community

[ACTIVE] Xim4 Not working  (Read 189 times)

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
[ACTIVE] Xim4 Not working
« on: 05:26 PM - 01/09/18 »
For some reason my xim4 is not recognizing my controller, mouse or keyboard im using a corsair k70 rgb rapidfire and a logitech g502 and the default xbox one controller i tried different usb ports updating the firmware and restoring to factory settings yet nothing seems to work not to mention i don't even get the blue flashing for bluetooth connectivity so i tried using the offline wired mode which only worked for one try then after that i simply got a usb device not recognized error everytime i tried plugging it in even restoring to factory defaults did not work. i even tried new cables that are meant for the xbox one controller yet nothing i have done has worked in fact things seem to have only gotten worse
« Last Edit: 05:33 PM - 01/09/18 by mist4fun »

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: Xim4 Not working
« Reply #1 on: 05:32 PM - 01/09/18 »
Welcome to the community. About your bluetooth issue, XIM4 startup lights should look like this.

red, green, blue
pause
red
cyan, green <-bluetooth initilization
red
green, green, green, green

Try starting XIM4 with nothing attached to its ports then check if you see the cyan green flash.

About your other issues, Can you answer these questions so we have a better idea of the issue?

1) Do you see a controller icon at the top of Manager's HUD screen?
2) Are you able to assign buttons to your mouse and keyboard or does it continue to say 'listening'?
3) Please share the firmware version number found in menu-about.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #2 on: 05:41 PM - 01/09/18 »
No controller icon and it never reaches the blue cyan color it stops at the red flashing/breathing and i'm not able to assign buttons
Version number is: 4.00.20171004

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #3 on: 05:45 PM - 01/09/18 »
Thanks. Let's try a hard reset, it can sometimes fix this issue. Press and hold the power button on the front of the console for 15 seconds. Once off unplug the power cable to the console for 60 seconds. Reconnect the power cable and power on the console. Attach all peripherals to XIM4 then connect XIM4 to the console.

On bluetooth, did you unplug all devices from XIM4 then connect XIM4 with all ports empty?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #4 on: 06:06 PM - 01/09/18 »
It still never reaches the blue cyan color or the green it simply stays breathing red and yes i unplugged all devices except the power cable and i tried the hard console reset which did nothing the xim still doesn't recognize the controller plugged into it and is completely non responsive along with the mouse and keyboard only the keyboard lights up the mouse does not nor does the controller it merely vibrates as it's connected then becomes unresponsive

i also tried different usb ports on the xbox and nothing changed yet the controller works just fine when wired directly to the xbox so i don't think its the cable
« Last Edit: 06:25 PM - 01/09/18 by NegloidNugNug »

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #5 on: 06:17 PM - 01/09/18 »
Thanks. Can you remove the controller battery then attach the controller directly to the console using the same controller cable? Do not use the XIM4 C cable. Does the controller light turn on automatically without pressing a button?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #6 on: 06:22 PM - 01/09/18 »
Yes it lights up automatically without the battery connected another issue seems to be the keyboard if i plug the keyboard into the xim4 and attempt to do offline wired configuration using the xim4 manager for windows 10 instead of the xim4 connecting it gives a usb device not recognized error yet if i plug in my mouse it doesn't do the same yet for some reason the mouse doesn't light up at all as if it's not connected and does not show up in the xim4 manager

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #7 on: 06:36 PM - 01/09/18 »
Thanks, your controller cable appears to be working. Could you try using a spare cable between XIM4 and console/PC?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #8 on: 06:57 PM - 01/09/18 »
i tried using a different cable and the result is still the same

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #9 on: 07:20 PM - 01/09/18 »
Are you able to factory reset using this firmware? Be sure to place XIM4 in programming mode first (solid blue).

http://xim.tech/latest
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #10 on: 09:30 PM - 01/09/18 »
i have tried a factory reset nothing has seemed to work at all
the factory reset goes through just fine

i believe i have been sold a defective xim4

not only does it never reach the  blue cyan color to indicate bluetooth connectivity it never detects my mouse or keyboard nor the controller plugged into it in the manager and god forbid i plug in my keyboard it causes the xim4 to flash yellow and throw an error and cause windows 10 to not recognize the usb device
« Last Edit: 09:40 PM - 01/09/18 by NegloidNugNug »

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #11 on: 09:32 AM - 01/10/18 »
Thanks for trying the reset. Yes, you should see activity from your bluetooth radio after a reset, using no connected peripherals, and changing cables. There may be an issue. Do you remember when and where you purchased XIM4?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #12 on: 12:05 PM - 01/10/18 »
yes i purchased the xim4 from sharktank media
should i make a rma through their website or should i try to get it repaired here because i really do not trust that vendor what so ever
« Last Edit: 12:19 PM - 01/10/18 by NegloidNugNug »

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 41332
    • View Profile
Re: [ACTIVE] Xim4 Not working
« Reply #13 on: 12:42 PM - 01/10/18 »
If you purchased recently you may want to contact them about a return or exchange, this would be the cheapest option. Otherwise you could create a ticket in our store to go over repair options using the link below. I'm sorry that this couldn't be fixed remotely.

https://store.xim4.com/crm.asp?action=add
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline NegloidNugNug

  • Member
  • *
  • Posts: 16
    • View Profile
  • Gamertag: NegloidNugNug
Re: [ACTIVE] Xim4 Not working
« Reply #14 on: 12:51 PM - 01/10/18 »
it's alright ill see if i can make a rma request through them but im not going to hold my breath last time i had to report them to the bbb just to get a email back on when my product would ship which still took them 4 weeks