XIM Community

[ACTIVE] Canít pair with iOS after following the instructions  (Read 179 times)

Offline Jesilicious

  • Member
  • *
  • Posts: 6
    • View Profile
Hi,
I downloaded the right Firmware for the xim and the latest version of xim4manager on iOS but they aren?t pairing. I don?t know if I have to be a game or anything to pair cos I followed the instructions for both and it?s still not working.

Please help.
« Last Edit: 09:09 AM - 10/12/17 by mist4fun »

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 29884
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Canít pair with iOS after following the instructions
« Reply #1 on: 09:19 PM - 10/11/17 »
Welcome to the community. You following these directions here specifically?: http://xim.tech/ios
Get the most out of your XIM4, read the XIM4 Support FAQ.

Offline Jesilicious

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Canít pair with iOS after following the instructions
« Reply #2 on: 10:10 PM - 10/11/17 »
Yes it just doesnt pair and gives me the pairing error.

Offline Aermo

  • Member
  • *
  • Posts: 3
    • View Profile
Re: Canít pair with iOS after following the instructions
« Reply #3 on: 06:24 AM - 10/12/17 »
I have done around 2 hours of reading research myself trying to fix this same issue.  Perhaps ios 11.0.2 was the issue as I just noticed 11.0.3 is out which I'm downloading now.  Will have to test when I get home. 

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 37405
    • View Profile
Re: Canít pair with iOS after following the instructions
« Reply #4 on: 09:08 AM - 10/12/17 »
What is the pairing error text?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Jesilicious

  • Member
  • *
  • Posts: 6
    • View Profile
Red screen with connect failure -1, it keeps going to that screen.

Offline Aermo

  • Member
  • *
  • Posts: 3
    • View Profile
Red screen with connect failure -1, it keeps going to that screen.

Yeah exactly. 

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 37405
    • View Profile
Jesilicious, let's check the status of bluetooth on both ends.

Is bluetooth enabled in your phone settings and are you able to pair this phone with other bluetooth devices?

On the XIM4 side, you should see cyan-green lights at startup. Example:

red, green, blue
pause
red
cyan, green   <-Here
red
green, green, green, green

You should also see the cyan-green light when pressing XIM4's P button. Do you see the cyan-green light in both instances?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 25403
    • View Profile
hey,

i have this too and to me it seems like its an issue with iOS and how it handles your communication channels from the lock screen control center
right now if you use the control center to activate or deactivate bluetooth, wlan, ... those will not properly activate or deactivate
for instance if you go into flightmode from the lock screen all your connection channels are still active but the large share of apps do not have access to internet, bluetooth and so on

for me i fixed it temporarily by fractivating and activating bluetooth from the iOS options itself, dont do it via the control center

here a link for more infos:
http://www.telegraph.co.uk/technology/2017/09/21/ios-11s-bluetooth-wi-fi-controls-dont-actually-turn-bluetooth/
PS4 & X1 | C: MS | XIM4 | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Zowie EC1-A | D: 3200 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

Check out my Youtube Channel: XIMGameplay
Du sprichst Deutsch? Hier gehts zum deutschen Forum

Offline NERF_THlS

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: NERF THlS
gonna give this a try

hey,

i have this too and to me it seems like its an issue with iOS and how it handles your communication channels from the lock screen control center
right now if you use the control center to activate or deactivate bluetooth, wlan, ... those will not properly activate or deactivate
for instance if you go into flightmode from the lock screen all your connection channels are still active but the large share of apps do not have access to internet, bluetooth and so on

for me i fixed it temporarily by fractivating and activating bluetooth from the iOS options itself, dont do it via the control center

here a link for more infos:
http://www.telegraph.co.uk/technology/2017/09/21/ios-11s-bluetooth-wi-fi-controls-dont-actually-turn-bluetooth/

Offline NERF_THlS

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: NERF THlS
so i went into settings activated airplane mode and turned on bluetooth. then turned airplone mode back off. left bluetooth on and it worked!

hey,

i have this too and to me it seems like its an issue with iOS and how it handles your communication channels from the lock screen control center
right now if you use the control center to activate or deactivate bluetooth, wlan, ... those will not properly activate or deactivate
for instance if you go into flightmode from the lock screen all your connection channels are still active but the large share of apps do not have access to internet, bluetooth and so on

for me i fixed it temporarily by fractivating and activating bluetooth from the iOS options itself, dont do it via the control center

here a link for more infos:
http://www.telegraph.co.uk/technology/2017/09/21/ios-11s-bluetooth-wi-fi-controls-dont-actually-turn-bluetooth/

Offline Aermo

  • Member
  • *
  • Posts: 3
    • View Profile
I messed around with the above advice and it finally worked yay.  But it's in a weird language, not English.  I know to fix I have to send my email to someone to get in the flight thingy or whatever haha.  Will look for that thread...

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 25403
    • View Profile
you dont have to use the flightmode it was just an example, usually it also works by deactivating and activating bluetooth alone in the iOS system settings :)
PS4 & X1 | C: MS | XIM4 | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Zowie EC1-A | D: 3200 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

Check out my Youtube Channel: XIMGameplay
Du sprichst Deutsch? Hier gehts zum deutschen Forum

Offline Jesilicious

  • Member
  • *
  • Posts: 6
    • View Profile
Jesilicious, let's check the status of bluetooth on both ends.

Is bluetooth enabled in your phone settings and are you able to pair this phone with other bluetooth devices?

On the XIM4 side, you should see cyan-green lights at startup. Example:

red, green, blue
pause
red
cyan, green   <-Here
red
green, green, green, green

You should also see the cyan-green light when pressing XIM4's P button. Do you see the cyan-green light in both instances?

When I have the manager up on iOS I press the P button on the spinning wheel then my xim lights up cyan then green then back to red and stays red.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 37405
    • View Profile
That's expected. The cyan-green flash will show one time then your XIM4 will continue to breathe the color of the config color which is red by default. Your XIM4 will continue to be in discovery mode for I think 30 seconds. You should be able to pair using the app during this period.

Did you try the suggested toggle on/off bluetooth in the phone settings mentioned above? Not in the lock screen control center?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos