XIM Community

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - nerdy

Pages: [1]
1
XIM APEX Discussions / Purchase with cryptocurrency
« on: 12:05 PM - 01/14/18 »
Will we be able to purchase the APEX with cryptocurrencies by any chance? Would help me in the end so I don't have to convert to fiat and get hit with fees from coinbase on top of taxes I would have to pay for the gains.

2
XIM 4 Discussions / Destiny No Land Beyond XIM4 gameplay
« on: 03:26 PM - 06/18/16 »
Sorry if this isn't the right place to post this, but I made a video with upload studio with some of my xim no land beyond clips I recorded and was hoping to get your opinions on it.

https://www.youtube.com/watch?v=EYnZPvnqFZY

Thank you.

3
XIM 4 Discussions / Xbox Headphone static
« on: 08:16 AM - 01/27/16 »
Xbox controller and XIM 4(20160121) are both up to date.

So I went and bought a Vmoda Boompro mic for my HD558 so I could use them with my xbox one, however it makes a really weird high pitch static noise whenever I have it plugged into my DSS2 and xbox contoller at the same time.



Here is my current setup. So far I have been able to stop the noise by either unplugging the xbox controller from the XIM4 or by removing the splitter from the chat adapter and not using the DSS2 at all. Other then that the headphones work fine with chat and audio if I just plug it straight into the xbox chat adapter with no splitters. Even with the spillters like in this picture http://i.imgur.com/jFwKerR.jpg it still works fine with chat and audio.

Anyone got any ideas as to why it would be making this kinda of sound?

4
Support / XIM Edge stuck in pc mode
« on: 07:20 PM - 01/30/13 »
So yea just got my edge today which was great, however I can't get it out of pc mode. It was working just fine before but after a game of gears it just stopped working. Ever time I connect it to the xbox with all my stuff plugged in it does its startup and then goes into pc mode. I have the latest firmware and did a factory restore about two times now. Nothing has worked. Please help. :(

Pages: [1]